I know this have been beat to death, but thought I would toss my experience in and get some advice. Last Sunday (of course on Sunday!) I has about 100 miles north of Denver, heading home towing my 5th wheel; about another 450 miles to go. After topping off with 19 gallons of diesel (tank was just under 1/2) I pulled back onto I-76 and before I got to the end of the on-ramp I got the "Low Fuel Pressure" warning. I continued a couple of miles to the next off-ramp; by the time I got there I had "reduced engine power", codes P008A and P0087 via my TorquePro app, a loud whine (low pressure pump?) and a rough running engine.

So, I'm sitting beside the interstate on Sunday afternoon trying to figure out what to do. The only option I really had was to change the fuel filters (I carry spares and tools). I drained fuel from both the OEM filters and my Donaldson filer (I have a Donaldson fuel/water filter separator prior to the OEM frame filter) and there was only a few drops of water from the Donaldson. After changing both OEM filters, I cleared the codes, the truck started right up (no whine) and never missed a beat for the 450 mile trip home, including going over Wolf Creek Pass.

So, what happened? I suspect that air got into the system, but how? It ran fine for about 6000 miles since my last filter change. Did re-fueling have anything to do with it? Do I have anything else to worry about like a bad low pressure pump? I changed the Donaldson filter as soon as I got home, so all three filters are new. I still have the old filters, any point in tearing them apart?

Thanks