PDA

View Full Version : Engine spuddering HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!



Hornetfixer
03-06-2006, 05:38 PM
Okay, need some help here. My truck used to just spudder around 45-55 mph. When I put my foot into it it stopped. Now, on take off from a dead stop, it spudders all the way through to 55 mph with moderate to light pedal pressure. When I stomp on it, it accellerates fine. It's been into Ford four times for the same problem and has a new cam sensor and emp sensor. The fuel pressure checked good, compressions good, fuel filter is new, new oil. It's pissing me off. The Ford mechanic talked with a tech rep last time it was in and was told to check all of the above and he did. He also told him that if it all checks good and the emp is switched out and it still does it, have me bring it back in and change the computer out. ?? It's even worse now than ever, does it cold and hot and now the truck a 102,115 mi. on it and the service guy says sorry no deal not covered anymore!! What the F$#@!!:angry::angry::angry::angry: Any thoughts? It's driving me nuts and my performance in the crapper too.:angry::angry:

mattymx
03-06-2006, 08:08 PM
Could be a few things, but I would start with cleaning the fuel pressure regulator. Even though you said FP is fine, the FPR can get clogged and show erratic running. Also look into the IPR (injection pressure reg.) Could be bleeding off oil pressure to the injectors until it reaches higher throttle operation. That is where I would start, but cant say for sure if that is your problem.

scotty
10-30-2006, 10:27 PM
My e350 7.3 seems to be doing about the same. I have a fair bit of smoke too, especilly on start up.
Scotty

scotty
10-30-2006, 10:28 PM
Does anyone think that it could be the IDM?